ExtremeSwitching (formerly BlackDiamond) Components: ExtremeXOS Software Support

Print Friendly

This section provides operating-system compatibility data for the ExtremeSwitching (formerly BlackDiamond) chassis-based components.

Note: When 16.x is listed as the last supported EXOS software version, the hardware is not supported in EXOS versions 21.1.1 and later but continues to be supported in all 16.x versions, for example 16.1 and 16.2. This pertains to the ExtremeSwitching X8 series (formerly BlackDiamond X series) and to some components in the ExtremeSwitching 8000 series (formerly BlackDiamond 8800 series).


ExtremeSwitching 8000 Series Switches: Software Support

BlackDiamond 8800 Series ComponentMinimum EXOS Software VersionMinimum BootROM VersionLast Supported EXOS Software Version
MSM-4811.6.1.91.0.1.1112.5.x
MSM-G8X11.6.1.91.0.1.1112.5.x
MSM-48c12.1.1.41.0.3.716.x
8800-MSM-9616.1.31.0.4.516.x
8500-MSM2412.3.11.0.4.215.6.x
8500-G48T-e12.3.11.0.4.015.6.x
8500-G24X-e12.3.11.0.4.015.6.x
8900-MSM12812.3.11.0.4.216.x
8900-10G24X-c12.3.11.0.1.016.x
8900-G96T-c12.3.21.0.1.016.x
8900-G48X-xl12.4.11.0.1.216.x
8900-G48T-xl12.4.11.0.1.216.x
8900-10G8X-xl12.4.11.0.1.216.x
8900-40G6X-xm12.6.11.0.1.216.x
G48T11.5.1.41.0.1.1012.4.x
G48Te11.5.1.41.0.1.1015.1.x
G48P11.5.1.41.0.1.1012.4.x
G48Pe11.5.1.41.0.1.1015.1.x
G48Ta11.5.1.41.0.1.1015.1.x
G48Xa11.5.1.41.0.1.1015.1.x
G48Tc12.1.1.41.0.3.716.x
G48Te212.1.1.41.0.3.716.x
G48Xc12.1.1.41.0.3.716.x
G24X12.1.1.41.0.3.712.4.x
G24Xc12.1.1.41.0.3.716.x
S-G8Xc12.1.1.41.0.3.716.x
S-10G2Xc12.6.11.0.1.216.x
10G4X11.6.1.91.0.1.1112.4.x
10G4Xa11.6.1.91.0.1.1115.1.x
10G4Ca12.0.1.111.0.1.1115.1.x
10G4Xc12.1.1.41.0.3.716.x
10G8Xc12.1.1.41.0.3.716.x
S-10G1Xc12.1.1.41.0.3.716.x
PSU Controller11.1.1.92.1316.x
700/1200 W AC PSU (Model # 60020/PS 2336)11.1.1.9N/AN/A
600/900 W AC PSU (Model # 41050/PS 2431) (8806 switch only)11.6.1.9N/AN/A
1200 W DC PSU (Model # 60021/PS 2350)11.3.2.6N/AN/A

Note: Upgrading the BootROM on an 8810 or 8806 switch is not automatic when software is upgraded. The user must be running the minimum required BootROM version or later. Use the install firmware command after upgrading the EXOS image to ensure that the BootROM is at the latest level.


ExtremeSwitching X8 Series Switches: Software Support

BlackDiamond X Series ComponentMinimum EXOS Software VersionMinimum BootROM VersionLast Supported EXOS Software Version
BDX-MM115.1.11.0.0.316.x
BDXA-FM10T15.1.11.0.0.616.x
BDXA-FM20T15.1.11.0.0.616.x
BDXA-G48X16.1.11.0.0.1216.x
BDXA-G48T16.1.11.0.0.1216.x
BDXA-10G48X15.1.11.0.0.616.x
BDXA-10G48T15.3.11.0.0.1116.x
BDXA-40G12X15.1.11.0.0.616.x
BDXB-40G12X-XL16.1.11.0.0.1216.x
BDXA-40G24X15.1.11.0.0.616.x
BDXB-100G4X15.5.11.0.0.1216.x
BDXB-100G4X-XL15.7.11.0.0.1216.x
AC Power Supply (Model # 48011)15.1.1N/AN/A

BlackDiamond 10808 Series Switches: Software Support

BlackDiamond 10808 ComponentMinimum EXOS Software VersionMinimum BootROM VersionLast Supported EXOS Software Version
MSM-110.1.01.0.1.515.1.x
MSM-1XL10.1.01.0.1.515.1.x
10G2H11.2.01.3.0.015.1.x
10G2X11.1.11.3.0.015.1.x
10G6X10.1.01.3.0.015.1.x
G20X11.1.11.3.0.015.1.x
G60T10.1.01.3.0.015.1.x
G60X10.1.01.3.0.015.1.x
PSU Controller10.1.0N/AN/A
700/1200 W AC PSU (Model # 60020/PS 2336)10.1.0N/AN/A
1200 W DC PSU (Model # 60021/PS 2350)11.3.2.6N/AN/A

BlackDiamond 10808 Modules with Rev. D ASIC Component Support

I/O Module8000 Level Part No.9000 Level Part No.Minimum EXOS Software VersionLast Supported EXOS Software Version
G60T804403-00 after Rev. 16904015-0011.2.1.315.1.x
804408-00 after Rev. 03904015-1011.2.1.315.1.x
G60X804402-00 after Rev. 16904009-00/1111.2.1.315.1.x
804404-00 after Rev. 03904009-1011.2.1.315.1.x
G20X804407-00 after Rev. 03904020-1011.2.1.315.1.x
804470-00 after Rev. 08904020-00/1111.2.1.315.1.x
10G2X804410-00 after Rev. 03904032-1011.2.1.315.1.x
804471-00 after Rev. 11904032-00/1111.2.1.315.1.x
10G2H804406-00, after Rev. 09904027-00/1111.2.1.315.1.x
804411-00 after Rev. 03904027-1011.2.1.315.1.x
10G6X804405-00 after Rev. 18904016-00/1111.2.1.315.1.x
804409-00 after Rev. 03904016-1011.2.1.315.1.x

BlackDiamond 12800 Series Switches: Software Support

BlackDiamond 12800 Series ComponentMinimum EXOS Software VersionMinimum BootROM VersionLast Supported EXOS Software Version
MSM-5 (BlackDiamond 12804)11.4.1.41.0.0.215.1.x
MSM-5 (BlackDiamond 12802)12.0.1.111.0.0.215.1.x
MSM-5R (BlackDiamond 12802)12.0.1.111.0.0.215.1.x
MSM-5R (BlackDiamond 12804)11.4.1.41.0.0.215.1.x
MSM-6R12.0.2.251.0.1.815.1.x
XM-2X12.2.2N/A15.1.x
XM-2HR12.1.1.4N/A15.1.x
XM-2XR11.4.1.4N/A15.1.x
GM-20T11.4.1.4N/A15.1.x
GM-20XT11.4.1.4N/A15.1.x
GM-20XTR11.4.1.4N/A15.1.x
PSU Controller11.4.1.4N/A15.1.x
700/1200 W AC PSU (Model # 60020/PS 2336)11.4.1.4N/A15.1.x
1200 W DC PSU (Model # 60021/PS 2350)11.4.1.4N/A15.1.x

BlackDiamond 20800 I/O Modules Support

BlackDiamond 20800 Series ComponentMinimum EXOS Software VersionFirmware Version Required with EXOS 12.5.1Last Supported EXOS Software Version
GM-40X12.3.2N/A15.1.x
HM-2X24GA12.5.1N/A15.1.x
XM-8X12.3.2N/A15.1.x
XFM-1 (shown as Fabric-1 through Fabric-5) (BlackDiamond 20808)12.3.2N/A15.1.x
XFM-2 (shown as Fabric-1 through Fabric-5) (BlackDiamond 20804)12.4.1N/A15.1.x
MM Basic12.3.2N/A15.1.x
Fan Tray (BlackDiamond 20808)12.3.2N/A15.1.x
Fan Tray (BlackDiamond 20804)12.4.1N/A15.1.x

Note: Use the check firmware version command to verify that all components on the BlackDiamond 20800 series switches (I/O modules, fans, and so on) are running the latest version of EXOS firmware. If the command output shows that one or more components are not running the latest firmware, use the install firmware command to update all down-level components. Be sure to run the show slot, show fans, show power, and show fabric commands to verify that all components are installed and operational before attempting to upgrade or downgrade the switch firmware.


We value your feedback about Extreme Networks documentation. Use our online feedback form to post a comment or suggestion about this information.

Want to be notified when this information changes? Sign up for email updates:

To be notified whenever this page is updated, supply your email address. We’ll use your email address only for sending these notifications.